How to mount an MS-DOS or NTFS drive

This section explains how to mount NTFS disks in FreeBSD.

NTFS (New Technology File System) is a proprietary journaling file system developed by Microsoft®. It has been the default file system in Microsoft Windows® for many years. FreeBSD can mount NTFS volumes using a FUSE file system. These file systems are implemented as user space programs which interact with the fusefs(5) kernel module via a well defined interface.

Procedure: Steps to Mount a NTFS Disk

  1. Before using a FUSE file system we need to load the fusefs(5) kernel module:

    # kldload fusefs

    Use sysrc(8) to load the module at startup:

    # sysrc kld_list+=fusefs
  2. Install the actual NTFS file system from packages as in the example (see Using pkg for Binary Package Management) or from ports (see Using the Ports Collection):

    # pkg install fusefs-ntfs
  3. Last we need to create a directory where the file system will be mounted:

    # mkdir /mnt/usb
  4. Suppose a USB disk is plugged in. The disk partition information can be viewed with gpart(8):

    # gpart show da0
    =>	  63  1953525105  da0 MBR   (932G)
    	  63  1953525105    1 ntfs  (932G)
  5. We can mount the disk using the following command:

    # ntfs-3g /dev/da0s1 /mnt/usb/

    The disk is now ready to use.

  6. Additionally, an entry can be added to /etc/fstab:

    /dev/da0s1  /mnt/usb	ntfs mountprog=/usr/local/bin/ntfs-3g,noauto,rw  0 0

    Now the disk can be now mounted with:

    # mount /mnt/usb
  7. The disk can be unmounted with:

    # umount /mnt/usb/

20.9.